WordPress 6.5.2 维护和安全版本

WordPress 发布了 6.5.2 维护和安全版本更新,该更新修复了商店跨站点脚本漏洞,并修复了核心和块编辑器中的十多个错误。同一漏洞同时影响 WordPress 核心和 Gutenberg 插件。

图片[1]-WordPress 6.5.2 维护和安全版本-糖果博客

跨站脚本 (XSS)

WordPress 中发现了一个 XSS 漏洞,该漏洞可能允许攻击者将脚本注入网站,然后攻击这些页面的网站访问者。

XSS 漏洞分为三种,但在 WordPress 插件、主题和 WordPress 本身中最常见的是反射型 XSS 和存储型 XSS。

反射型 XSS 要求受害者点击链接,这是一个额外的步骤,使得此类攻击更难发起。

存储型 XSS 是更令人担忧的变体,因为它利用了一个缺陷,允许攻击者将脚本上传到易受攻击的站点,然后对站点访问者发起攻击。 WordPress 中发现的漏洞是一个存储型 XSS。

威胁本身在一定程度上得到了缓解,因为这是经过身份验证的存储型 XSS,这意味着攻击者需要首先获得至少贡献者级别的权限,才能利用使漏洞成为可能的网站缺陷。

该漏洞被评为中等威胁,通用漏洞评分系统 (CVSS) 评分为 6.4(评分范围为 1 – 10)。

Wordfence 描述了该漏洞:

“由于显示名称上的输出转义不足,在 6.5.2 及之前的各个版本中,WordPress Core 很容易通过 Avatar 块中的用户显示名称受到存储跨站点脚本攻击。这使得具有贡献者级别及以上访问权限的经过身份验证的攻击者可以在页面中注入任意 Web 脚本,每当用户访问注入的页面时就会执行这些脚本。”

建议立即更新

由于这是一个安全版本,因此建议您立即更新网站。向后移植也可用于其他主要的 WordPress 版本,6.0 及更高版本。

© 版权声明
THE END
喜欢就支持一下吧
点赞11赞赏 分享
评论 抢沙发

请登录后发表评论

    暂无评论内容